Joomla! 3.0 Preguntas Frecuentes


El Equipo de Marketing para Joomla! versión 3.0 ha estado trabajando en una serie de preguntas estimadas como las más frecuentas en lo relativo al lanzamiento de Joomla! 3.0, considerando que la nueva versión acaba de ser liberada hace unos días, es propio entregarle a los lectores de la Joomla! Magazine, la versión de estas preguntas frecuentes en español.

¿Cuáles son las mayores diferencias entre Joomla! 2.5 y Joomla! 3.0?

La más notable diferencia es una administración totalmente renovada, la cual ha sido actualizada a un diseño más moderno con interfaces para el usuario más simples y amigables. Además, Joomla! 3.0 es adaptable a dispositivos móviles, por lo que puede ser usada en cualquier dispositivo moderno.

Adicionalmente, hay docenas de mejoras en todo Joomla!, tales como un nuevo instalador, el cual verás al momento de crear una nueva instalación o en el momento en el que actualizas a Joomla! 3.0. Por último, Joomla! 3.0 ha sido empaquetada con algunos obsequios para los desarrolladores de extensiones, tales como el soporte a Bootstrap y el soporte a JQuery.

Estoy desarrollando un nuevo sitio desde cero, ¿Debo hacerlo con Joomla! 2.5 o con Joomla! 3.0?

Si lo que buscas es la mayor estabilidad que Joomla! tiene para ofrecer y/o la posibilidad de instalar múltiples extensiones, entonces debes lanzar tu sitio con Joomla! 2.5. En cambio, si las extensiones que planeas utilizar ya son compatibles con Joomla! 3.0, entonces puedes lanzarlo con Joomla! 3.0. Solo algunos proveedores de plantillas y algunos desarrolladores de extensiones están preparados para Joomla! 3.0, la mayoría de estos no estarán listos, al menos no lo estarán en los próximos días, semanas e incluso meses más.

Si lanzo un sitio web con Joomla! 3.0, ¿Voy a tener la posibilidad de instalar extensiones?

Sí, podrás instalar extensiones que sean compatibles con Joomla! 3.0, el Centro de Extensiones de Joomla! te mostrará un ícono que indica que la extensión es compatible con Joomla! 3.0, aún así, el mejor lugar para revisar si la extensión es o no compatible con Joomla! 3.0 es desde el sitio web del desarrollador de la extensión.

¿Cómo puedo obtener una plantilla (template) para Joomla! 3.0?

Algunos proveedores de plantillas, al momento de esta publicación, ya están ofreciendo plantillas compatibles con Joomla! 3.0, pero para saber quienes son, debes ir revisando en el sitio web de cada uno de ellos. En todo caso, algunos ya había anunciado que sus plantillas serían compatibles al momento del lanzamiento de Joomla! 3.0, pero otros no habían dicho nada al respecto.

¿Cómo encuentro extensiones compatibles con Joomla! 3.0?

Visita el centro de extensiones de Joomla!, el cual te mostrará en el listado de extensiones, las que ya son compatibles con Joomla! 3.0, como sea, te insistimos, el mejor lugar para estar al día respecto a la compatibilidad de tus extensiones, es el sitio web del mismo desarrollador.

Mis extensiones de Joomla! 2.5, ¿Funcionarán en Joomla! 3.0?

Las extensiones que fueron desarrolladas nativamente para Joomla! 2.5 debieran funcionar en Joomla! 3.0 con muy pocos cambios, si que hubiese que hacer alguno. Los componentes y plantillas demandarán un poco más de trabajo para hacerlos compatibles, en cambio, los módulos y plugins deberían funcionar sin problemas (Asumiendo que no usaron métodos obsoletos). Las extensiones que han sido desarrolladas para soportar Joomla! 1.5 y Joomla! 2.5 en el mismo paquete de instalación no van a funcionar en Joomla! 3.0, al menos hasta que el desarrollador trabaje en su actualización para asegurar la compatibilidad.

El proyecto Joomla! ha realizado un proceso relativamente simple para la mayoría de las extensiones, aún así algunas extensiones van a requerir un poco más de trabajo. Se te recomienda que le comentes a tu proveedor de extensiones que deseas utilizar sus extensiones en Joomla! 3.0.

¿Qué sucede si lanzo un sitio web con Joomla! 3.0, pero la extensión que deseo es para Joomla! 2.5?

Necesitas ponerte en contacto con el proveedor de extensiones para ver si tienen proyectado actualizar sus extensiones a Joomla! 3.0 en un futuro inmediato. Los desarrolladores deben realizar algunos cambios en sus extensiones, pero qué tan complejos pueden llegar a ser esos cambios depende sólo de la extensión.

¿Debo actualizar a Joomla! 3.0 desde Joomla! 2.5?

En la mayoría de los casos no es necesario. Joomla! 2.5 continuará su soporte hasta mediados de 2014, por lo tanto, puedes perfectamente bien esperar hasta el lanzamiento de la versión 3.5 que será la próxima versión de soporte largo para realizar tu actualización. Las únicas razones por las que deberías actualizar ahora es porque necesitas de alguna de las nuevas características de Joomla! 3.0 o deseas estar entre los primeros que comenzaron a trabajar con esta nueva versión.

Tengo un sitio corriendo con Joomla! 2.5 y veo que desde el Gestor de actualizaciones de Joomla! se me permite actualizar a Joomla! 3.0, ¿Debo hacerlo, considerando que el actualizador me lo permite?

No, a menos que estés 1000% seguro de lo que estás haciendo. Por defecto, Joomla! no te dejará actualizar a la versión 3.0 a menos que tu mismo actives la opción dentro del componente de Actualizaciones de Joomla! (Administrador >> Componentes >> Actualización de Joomla! >> Opciones >> Origen de la actualización >> Soporte de Corta Duración – STS). Si por alguna razón modificaste esos parámetros y te gustaría dejar de recibir notificaciones de actualizaciones de Joomla! 3.0, modifica el parámetro a la opción “Soporte de larga duración”. Una vez realizado ese cambio dejarás de recibir avisos de actualizaciones de Joomla! 3.0 y recibirás solo las de Joomla! 2.5.

¿Qué viene después de Joomla! 3.0?

En 6 meses más se realizará el lanzamiento de Joomla! 3.1. Si ya estás trabajando en ese momento con Joomla! 3.0, entonces deberás actualizar a la nueva versión, si te habías mantenido en Joomla! 2.5, puedes continuar usando 2.5 y esperar al lanzamiento de Joomla! 3.5.

Listo, Estoy listo y quiero actualizar a Joomla! 3.0, ¿Qué debo hacer?

  1. Revisa los requerimientos de sistema para Joomla! 3.0 y asegúrate que el entorno de trabajo de tu servidor cumple con todos los requisitos.
  2. Asegúrate que todas tus extensiones (especialmente tu plantilla) sean compatibles con Joomla! 3.0.
  3. Consulta con un desarrollador de confianza si no estás 100% seguro respecto a cualquier detalle.
  4. Crea un sitio de pruebas y actualiza en ese sitio primero.
  5. Haz un completo respaldo de tu sitio (Archivos y Base de Datos).

Una vez que estés listo, anda al componente de Actualización de Joomla!, haz click en las opciones y cambia los parámetros a “Soporte de corta duración” y guarda los cambios. De inmediato debieras ser notificado de la disponibilidad de Joomla! 3.0, haz click en el botón instalar, limpia la caché de tu navegador para asegurarte de ver los últimos cambios y ¡listo!.

Finalmente, Vuelve a revisar y asegurate que todo esté funcionando correctamente.

Nota: En algunas compañías de hosting podría ser que debieras usar métodos alternativos de actualización, tales como el gestor de extensiones.

Pero yo aún estoy en Joomla! 1.5 ¿Dejará de funcionar mi sitio?, ¿Debo migrar a 2.5 o 3.0?

El soporte para Joomla! 1.5 está oficialmente terminando. ¿Significa eso que tu sitio dejará de funcionar?, No, tu sitio seguirá funcionando tal como ha funcionado hasta ahora, pero… Los desarrolladores de Joomla! no continuarán desarrollando nuevas versiones para Joomla! 1.5, por lo que no tendrás reparaciones a errores o parches a potenciales fallos de seguridad, por esta razón es recomendable que migres desde la versión 1.5.

Migrar desde Joomla! 2.5 a Joomla! 3.0 es relativamente simple, esto debido a la facilidad que se le ha puesto al proceso en las nuevas versiones. Desafortunadamente, migrar desde 1.5 no es una tarea simple. Afortunadamente hay 2 buenas extensiones que harán el proceso más simple, jUpgrade y SP Upgrade.

Tienes la opción de migrar directo a Joomla! 3.0 o migrar a Joomla! 2.5. Ambas extensiones, SP Upgrade y jUpgrade tienen versiones preparadas para ambos casos. Por favor, revisa la documentación publicada en “¿Cómo migrar de Joomla! 1.5 a 3.0/2.5?”.

Migra a Joomla! 3.0 si todas las extensiones que tienes planeado usar son compatibles con esta versión. Recuerda que solo algunos proveedores de plantillas y extensiones ya están preparados para la nueva versión.

 

Documentacion GRACIAS a http://magazine.joomla.org

Anuncios

Acerca de ncastillo

Soluciones Libres Dominicana Soluciones Libres Dominicana, Una empresa proveedora de servicios tecnológicos dedicada a brinda soluciones y servicios de nivel para grandes corporaciones y empresas en crecimiento (Pyme) especialmente. Aseguramos Escalabilidad, Integración e Innovación, alta competitividad y costos a su medida. Somos empresa que diseña soluciones tecnológicas exclusivas para cada cliente, simplificando así la incursión de su organización en el mundo de las nuevas tecnologías de información y comunicación. Trabajamos con tecnologías Open Source, para abaratar y reducir los costos en licenciamientos, con infraestructuras completamente estables y redundantes. No especializamos en redes avanzadas, Firewal Open Source, como de cualquier marca de la que existen en el mercado (como Fortinet, Sophos, Wacthguard, Palo alto, Cisco ASA. Implementaciones de redes LAN/WAN, Wireless, Servicios en la nube, diseño de página Web, Hosting hecho para cualquier medida. Tecnologías hibridas, somos especialista en Microsoft Windows 2012, Mac OS X, Hyper-V, VMWare, RedHat, Ubuntu Server, Debían. Somos especialista de página web para ecomerce, tu negocio en línea con todas la seguridad y cumpliendo con todos los requerimientos de una tienda en línea (PCI), certificado SSL, unificación de medios de pagos como Paypal. Consolidamos tu tiene en línea de Amazon o EBay con tu propia página web ecomerce. Infraestructura de servidores, basado en chasis blade, (Dell, HP, Cisco UCS Mini, Configuración de Storage eQualogic, EMC. Soluciones Libres Dominicana, es pionera y líder en Santo Domingo, República Dominicana en el uso de GNU/Linux y está especializada en grandes soluciones usando Open Source y Software Libre. En el equipo contamos con profesionales que trabajan hace varios años con soluciones libres, con más de 15 años de experiencia. WebSite Oficial http://www.tecnologialibre.net Twitter : @TecnoLibreDR FaceBook : https://www.facebook.com/TecnologiaLibre.Net

Publicado el Lunes, octubre 8, 2012 en Apache, Apple, Articulos, Joomla, Joomla 1.6, Joomla 1.7, Joomla3.0 y etiquetado en . Guarda el enlace permanente. Deja un comentario.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: